740B WIFI Connectivity

divertim

New member
Joined
Jun 24, 2023
Messages
4
Reaction score
0
My new 740B will not connect to WIFI. I watched the videos, read the manual, followed the direction ... and still nothing, even with the unit next to the router/modem.
 
Unfortunately, there are some quirks with the 7xx devices' wifi support.

Does the device at least see that there is a wifi network out there? If not, then there's probably a hardware issue.

If it sees the network, but just won't connect, then do you have any other "known" networks with saved login credentials? (On the 700 and 720, these were annotated with a "(Pre)" in the network name; the 740 also has a way to indicate a "remembered" network, but I think it might say something different--I don't have a 740, so I don't know exactly.)

If it does, try making the 740 "forget" those saved credentials for other networks, and then try again to make your connection. For whatever reason, the 7xx devices don't behave well going back-and-forth between different networks with stored login credentials. It's just better to delete all those stored credentials, and enter them fresh each time you change networks.

What's even better is only ever connecting the 740(b) to a single network (like the one you use in the plane), and don't try going back-and-forth between different networks. If you need to update the data on the 740, pop out the SD card and use iFly Connect on a Windows computer to do that. You can find the link to iFly Connect here: https://iflygps.com/Home/Update-iFly-Portables/Instructions
 
I deleted all profiles (Pre). When the unit is in settings under WIFI, it sees my neighbors' networks but won't see mine. Mine is working just fine as I have multiple devices connected to it.

The WIFI not working on the 740b negates a big reason for purchasing it...being able to update without a computer/card reader.

Very disappointed, I could have purchased a nice iPad and been way ahead.
 
It's very strange that it sees your neighbors' networks but not yours.
 
As a long time user of the 7XX series of equipment, As Cobra says delete all networks except for the aircraft and update the SD card using Ifly connect. At the time I guess that it sounded great, but in reality it just does not work.
 
I second what Alpine says. It sounds like your router is only putting out a 5GHz signal. I'm sure the 740 must use 2.4GHz. Check your router.
 
The other thing is you can mask your SSID. Many access points have a setting called broadcast your network name. Make sure that is checked or turned on. If you are concerned about it from a security standpoint, turn it on and set it up on the 740 then turn it back off. Will work fine after, if that is what the issue is.
 
Back
Top